PhpDig.net

Go Back   PhpDig.net > PhpDig Forums > Script Installation

Reply
 
Thread Tools
Old 02-01-2004, 09:32 PM   #1
vinyl-junkie
Purple Mole
 
Join Date: Jan 2004
Posts: 694
Installation Problems On A Second Website

I've successfully installed and configured phpdig on one of my websites. Now I'm trying to do it on the other and have run into some problems.

I manually created my database and tables, assigned a username and password to the database, and I've compared what my config.php file looks like between the two websites. Everything seems in order, yet I'm getting some errors. For what it's worth, the site I'm having problems with is on a Windows server, while the one on which I successfully installed phpdig is on Linux.

Here's a sampling of the errors. Perhaps someone can tell me what I'm doing wrong. Thanks.
Code:
Notice: Undefined index: SCRIPT_FILENAME in 
c:\hosting\webhost4life\member\vinyljunkie2\search\includes\config.php 
on line 19

Notice: Undefined index: REQUEST_URI in
c:\hosting\webhost4life\member\vinyljunkie2\search\includes\config.php 
on line 20
vinyl-junkie is offline   Reply With Quote
Old 02-02-2004, 12:33 AM   #2
CCC
Green Mole
 
Join Date: Feb 2004
Posts: 2
I got the same. Some research convinced me that this was possibly due to use of MS IIS instead of Apache. The "$_SERVER" variables are sent by the server. So that's probably it.

There is an if statement in config.php, which ensures that you are not trying to run it by itself. If you comment out the if statement it seems to work...

...although just make sure you're not loading it directly. Or wait for someone with more experience with the system
CCC is offline   Reply With Quote
Old 02-02-2004, 06:05 AM   #3
vinyl-junkie
Purple Mole
 
Join Date: Jan 2004
Posts: 694
Thanks for the help! That did the trick for one problem, but now I'm having another and I'm not sure how to modify the code to get around it.

When I go to the admin/index.php and get the screen that asks for my username and password, I enter those two things, and the screen comes back with:

www.techtipscentral.net\mypassword

in the username field.

www.techtipscentral.net is the domain I'm running this from.

I tried appending "www.techtipscentral.net\" to the user variable definition in both the config.php and auth.php files (sans quotes, of course), but that didn't work. I'll admit I'm out of my element on this.

I'm sure this is another Windows server related problem, but why is this tacking on the domain name and a backslash to the password, and how do I get around that one?

Side Comment: Now I know why I switched my main website to Linux.
vinyl-junkie is offline   Reply With Quote
Old 02-02-2004, 07:41 AM   #4
vinyl-junkie
Purple Mole
 
Join Date: Jan 2004
Posts: 694
Just wanted to say that I found some code on another forum here which looks like it addresses my problem. I'll work with it later today, then if I'm successful I'll post the modifications that I made to my phpdig code to get it to work.
vinyl-junkie is offline   Reply With Quote
Old 02-02-2004, 09:22 AM   #5
vinyl-junkie
Purple Mole
 
Join Date: Jan 2004
Posts: 694
I just cannot figure this thing out. What would help, I think, is if I could make my own authentication form like that other forum's post that I mentioned. I have no idea how to modify the code to do that.

Unless someone can help, I don't think I'll be able to use phpdig on my Windows server site.
vinyl-junkie is offline   Reply With Quote
Old 02-03-2004, 08:46 PM   #6
CCC
Green Mole
 
Join Date: Feb 2004
Posts: 2
The problem can be traced to use of $_SERVER in auth.php. This appears to be another point where the values returned by MS IIS differ from Apache.

The microsoft website suggests that such authentication is impossible: however, this page tells you how to go about it with PHP 4.3.3+ (near the bottom of the page, just above user comments). Haven't tested it yet, but I hope this helps.
CCC is offline   Reply With Quote
Old 02-03-2004, 09:17 PM   #7
vinyl-junkie
Purple Mole
 
Join Date: Jan 2004
Posts: 694
Quote:
Originally posted by CCC
The problem can be traced to use of $_SERVER in auth.php. This appears to be another point where the values returned by MS IIS differ from Apache.
True. In fact, what I found by setting an echo statement in the code is that the $_SERVER variables aren't even getting set in IIS!

I have an idea on modifying the code that I think will work with IIS as well as Apache, and will likely be more secure to boot. I'm working on it right now, but haven't had much time so not much progress.

Basically, I'm going to create a form within auth.php and require the user to enter username and password there. Then I created another database with just a single table with usernames and passwords. The idea is to compare the form entry to the database to authenticate the user.

As an added measure of security, the user will get 3 tries to enter the information correctly. If they fail, they will be redirected to my home page. Hopefully, that's all it will take to have the necessary security.

If I'm successful, I'll post the code in the Mod Submissions forum. Wish me luck!
vinyl-junkie is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2 PHPDigs in 1 server? Installation problems aladdin610 Script Installation 2 02-04-2006 07:25 PM
Cannot spider my website... nodoyuna Troubleshooting 12 11-11-2005 08:32 PM
Spidering Problems on a Windows Server Website vinyl-junkie Troubleshooting 23 02-20-2004 07:44 PM
Problems with installation ekieke Script Installation 5 01-21-2004 12:04 PM
installation problems jive Script Installation 3 10-28-2003 08:15 PM


All times are GMT -8. The time now is 11:16 AM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Copyright © 2001 - 2005, ThinkDing LLC. All Rights Reserved.