PhpDig.net

Go Back   PhpDig.net > PhpDig Forums > Bug Tracker

Reply
 
Thread Tools
Old 05-10-2005, 02:36 PM   #1
xdaniel
Former Member
 
Join Date: May 2005
Posts: 3
cron again

Hello Charter and all the others,

maybe I am too stupid, but I'm one step away from what I wanted and can't get it running (Version 1.8.7).

I tried almost every hint in this board the last two nights, but I can't get the cronjob working. I don't want my Workstation let running all the nights to spider the server.

When I try:

cd /pages/mydirectory/admin
php -f spider.php forceall > spider.log

everything works fine.

But if I try to use the cronjob using the full path how you described, I get all the errors like "warning, can't include...on line 96...115"

Is there anyone who can explain completely and step by step how to use it?

There are a lot of fragments and I think I made any important fault? Or is there anyone who can install it for me?

Best wishes from a boy getting gray hairs and crying for help... :-)

Daniel
xdaniel is offline   Reply With Quote
Old 05-10-2005, 02:53 PM   #2
Charter
Head Mole
 
Charter's Avatar
 
Join Date: May 2003
Posts: 2,539
Go into spider.php and comment out the following:
Code:
    // echo $relative_script_path;
    $relative_script_path = '..';
And then try the cron job again. Work now?
__________________
Responses are offered on a voluntary if/as time is available basis, no guarantees. Double posting or bumping threads will not get your question answered any faster. No support via PM or email, responses not guaranteed. Thank you for your comprehension.
Charter is offline   Reply With Quote
Old 05-10-2005, 10:44 PM   #3
xdaniel
Former Member
 
Join Date: May 2005
Posts: 3
Hi Charter,

I just to tried the script from the commandline using full path and it works now! I try the cronjob this evening and tell you the results.

Thanks a lot!

Best wishes from Cologne

Daniel
xdaniel is offline   Reply With Quote
Old 05-11-2005, 10:55 PM   #4
xdaniel
Former Member
 
Join Date: May 2005
Posts: 3
Hi Charter,

you were right. Now it worked. Thanks a lot!

Daniel
xdaniel is offline   Reply With Quote
Old 05-12-2005, 08:33 AM   #5
Charter
Head Mole
 
Charter's Avatar
 
Join Date: May 2003
Posts: 2,539
Okay, thanks. Moved to bugs...
__________________
Responses are offered on a voluntary if/as time is available basis, no guarantees. Double posting or bumping threads will not get your question answered any faster. No support via PM or email, responses not guaranteed. Thank you for your comprehension.
Charter is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Looking for cron tutorial grassmonster How-to Forum 0 07-07-2007 10:33 AM
Locking using Cron Slider Troubleshooting 8 01-13-2005 01:32 AM
cron problem Warmbells Troubleshooting 4 12-23-2004 06:33 PM
Win2000 Cron duffy Troubleshooting 2 12-16-2004 05:43 AM
prblem with cron franklin74 Troubleshooting 5 10-08-2004 08:56 AM


All times are GMT -8. The time now is 04:55 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright © 2001 - 2005, ThinkDing LLC. All Rights Reserved.