PDA

View Full Version : Excludes not working although properly set


jbafaure
05-01-2004, 06:02 AM
Hi !

I'm currently running PhpDig version 1.8.0, and unfortunately, the comments <!-- phpdigExclude --> and <!-- phpdigInclude --> seem to have no effect. The content between them is still indexed.

Before posting this message, I made a comprehensive search in the forum, I found that each comment should be on a single line. That's done. So, I don't understand where the problem is coming from ? Maybe my version of PHP is too old ? My host runs 4.1.2, certified by Sun, and I can't change for another host at the moment.

Any help would be greatly appreciated !

Many thanks :)

Charter
05-01-2004, 06:28 AM
Hi. Try this (http://www.phpdig.net/showthread.php?threadid=763) thread.

jbafaure
05-01-2004, 10:58 AM
Thank you Charter for your reply :)

I've read this thread before posting, but unfortunately it doesn't solve my problem.

If you have any idea please let me know...

Best regards.

Charter
05-01-2004, 11:12 AM
Hi. When you look at the HTML source for the pages using the exclude/include comments, are they each on their own line?

jbafaure
05-01-2004, 11:40 AM
Yes, they are on their own line, and everything is correct in the config file. Thank you again Charter for your help :)

Charter
05-01-2004, 11:51 AM
Hi. The exclude/include comments are case sensitive. Are you using phpdigexclude/phpdiginclude or phpdigExclude/phpdigInclude? Do a double check and see if what is defined in the config file is what is used in the HTML output.

jbafaure
05-01-2004, 02:16 PM
Hi Charter !

I effectively checked the case in both the config file and the HTML output, and they appear to be the same (phpdigExclude and phpdigInclude).

Nevertheless, I must tell you that I wanted to prevent the meta tag "description" from being indexed by PhpDig. I think that I've found the solution in robot_functions.php, and it seems to work now.

But will the comments phpdigExclude and phpdigInclude will elsewhere in the page, for example between the <body> and </body> tags of the page instead of the <head> and </head> tags ? Furthermore, the indexing process seems much slower with 1.8.0 than it was with 1.6.2 (that I was using before). Is there a solution for that ?

Thank you again !

Charter
05-01-2004, 05:46 PM
Ah, see this (http://www.phpdig.net/showthread.php?threadid=555) thread about meta tags. The exclude/include tags are for within the body of your pages. As for speed, 1.8.0 does more processing and there is a "courtesy" resource pause. Maybe this (http://www.phpdig.net/showthread.php?threadid=845) and/or this (http://www.phpdig.net/showthread.php?threadid=543) thread would be of interest.

jbafaure
05-02-2004, 09:46 AM
Hi Charter !

Thank you alot for your very effective support ! It's very nice to see that for a FREE, and professional-class script like PhpDig :)

My problem is now solved for the meta tags, and i optimized the search.php and robot_functions.ph files to make the indexing process a little bit faster.

Best Regards,

JBF