PDA

View Full Version : It's a classic: No link in temporary table / links found : 0


schade
02-13-2004, 06:58 AM
Hi,

I have a problem when trying to index my server. Installation went fine, but when trying to index I get:

Spidering in progress...

--------------------------------------------------------------------------------
SITE : http://www.kvis.org/
Exclude paths :
-
- @NONE@
No link in temporary table

--------------------------------------------------------------------------------

links found : 0
...Was recently indexed
Optimizing tables...
Indexing complete !

Phpdig is installed on the same server www.kvis.org. When I try to index another server e.g., www.schade.dk it just works fine. It seems to have a problem with 'localhost'.

PHP is running in CGI-mode, SAFE mode is off, running 1.8.0. What could be wrong?

It seems like I have the same problem at described
Here (http://www.phpdig.net/showthread.php?s=&threadid=346&highlight=No+link+in+temporary+table) . But they newer found a solution.

Charter
02-14-2004, 12:40 PM
Hi. Perhaps try this (http://www.phpdig.net/showthread.php?threadid=310) thread or this (http://www.phpdig.net/showthread.php?threadid=514) thread.

schade
02-20-2004, 04:18 AM
Hi.

I've now tried to install phpdig on another server. When trying to indes www.kvis.org I still get "No link in temporary table / links found : 0 ". Would anyone please try to index it, and let me know if you succeded?

Charter
02-20-2004, 06:07 PM
Hi. My initial guess is that the phpdigReadRobotsTxt function and/or the phpdigDetectDir function, both in the robot_functions.php file, may need some reworking.

TiM
03-04-2004, 12:31 PM
Same here. www.doska.lv, rus.delfi.lv fails but for example www.audiclub.lv fine. No NAT and other network crazy things - direct connection (DC). Please inform how to fix it ASAP. :confused:

Charter
03-04-2004, 01:37 PM
Hi. Perhaps try the file attached in this (http://www.phpdig.net/showthread.php?threadid=573) thread.

TiM
03-04-2004, 01:56 PM
Please test this on www.doska.lv and www.garmtech.lv. After patch this sites still doesn't want to crawl.

Charter
03-04-2004, 02:30 PM
Hi. Try crawling

http://doska.lv/ and http://garmtech.lv/

instead of

http://www.doska.lv/ and http://www.garmtech.lv/

TiM
03-04-2004, 03:47 PM
Cool! It helps. But can somehow automate this for redirected links too?

Did you plan to enable redirect patch intro new version (and robots.txt comments too)?

Charter
03-04-2004, 04:14 PM
Hi. I think that the www versus not having it is a resolving issue depending on the host. Currently nothing in PhpDig tests this specifically, but rather the file here (http://www.phpdig.net/showthread.php?threadid=573) is for those cases where there is a header redirect in place like so:

$url = "http://www.doamin.com/dir/file.php?query=string";
header("location: $url");

If you are referring to this (http://www.phpdig.net/showthread.php?threadid=595) thread and robots.txt files, assuming the comments are on their own lines, then the phpdigReadRobotsTxt function should just ignore them.

As for new versions, while there is no guarantee that any requests/mods will make it into a new version of PhpDig, the Mod Requests (http://www.phpdig.net/forumdisplay.php?forumid=23) and Mod Submissions (http://www.phpdig.net/forumdisplay.php?forumid=24) forums are where I'll look for further suggestions.