PhpDig.net

Go Back   PhpDig.net > PhpDig Forums > Troubleshooting

Reply
 
Thread Tools
Old 01-19-2005, 10:50 AM   #1
BulForce
Orange Mole
 
Join Date: Aug 2004
Location: none
Posts: 33
Exclamation URGENT! Probably a seriose bug.

Straight to the point.

After upgrade my digger from 1.8.3 to the lastest at the moment 1.8.7, i have run an command line indexing

php -f spider.php sites.txt >> sites.log

The sites.txt file contains about 2000 pages. All was fine, exept that i have notice that the spidering proccess was about 2 times slower than previose version(1.8.3). And i leave it to index and go to bed. Today when i woke up, look at the shell and notice following message:

Terminated!

Look in the sites.log and saw that around 1600 was indexed. I have run the spider again, and in 10 minutes i recive a phone call from the server tech admin. He tells me that my account have been sent about 25-35 emails per second, and this makes him to kill the proccess that creates them. I tells him what kind of script i run and that i dont think that this can be the source of this emails. Then we make a test: I run the spider again and he was still on the phone and tell me that this mails have start again.

Now i cant run the spider becouse he explain me, that this (mass mailing) can couse my account to be shuted down.

Any help and ideas will be apreciated.
Thank you
BulForce is offline   Reply With Quote
Old 01-19-2005, 11:06 AM   #2
Charter
Head Mole
 
Charter's Avatar
 
Join Date: May 2003
Posts: 2,539
PhpDig has not one mail command and does not hook up to any mail process. Before this can be declared a bug, I would need more information. For starters, what is the content of the email?
__________________
Responses are offered on a voluntary if/as time is available basis, no guarantees. Double posting or bumping threads will not get your question answered any faster. No support via PM or email, responses not guaranteed. Thank you for your comprehension.
Charter is offline   Reply With Quote
Old 01-19-2005, 11:33 AM   #3
BulForce
Orange Mole
 
Join Date: Aug 2004
Location: none
Posts: 33
I have request same thing from tech admin and still waiting to recieve the server logs. Will post here when got them
BulForce is offline   Reply With Quote
Old 01-20-2005, 03:14 PM   #4
BulForce
Orange Mole
 
Join Date: Aug 2004
Location: none
Posts: 33
The tech admin inform me, that the company owner refuse to give me the logs without any reason. He tells me to make tests on localmachine in order to see what happen.

I will build a linux machine these days and will make the tests.
BulForce is offline   Reply With Quote
Old 01-20-2005, 05:11 PM   #5
Dave A
Purple Mole
 
Dave A's Avatar
 
Join Date: Aug 2004
Location: North Island New Zealand
Posts: 170
I feel that Charter is correct, never once has my version of phpdig ever sent any emails because it doesn't appear to be built into the software.
A while ago I did have a problem with a web hosting company getting worried about ******d connections, when the spider started to index web sites.
They complained about the bandwidth that I may end up using, well I simply changed hosting providers.
Some web hosts get worried that any ******d connections may be spam related, it may be worth informing them of what phpdig does, if they are not used to ******d connects it may be that they have become confused by what the spider is doing.
But Charter is very clever and knows the software indside out, trust him I do..
This morning at about eight "Wellington in New Zealand" had another earthquake and it actually managed to shake my bed.
For the first time in my life the bed shook... Grin
Goday everyone.
Dave A is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Urgent: Lots of problems please help lochie1979 Troubleshooting 0 10-04-2006 10:21 AM
Do i need help or is it a bug? se7en Troubleshooting 2 03-16-2006 07:23 AM
Not really a bug cybercox Mod Requests 0 04-04-2004 07:03 AM
PhpDig - Urgent Charter Feedback & News 0 01-14-2004 02:29 PM
bug... shadow00 Troubleshooting 2 12-16-2003 01:01 PM


All times are GMT -8. The time now is 03:47 AM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright © 2001 - 2005, ThinkDing LLC. All Rights Reserved.