PhpDig.net

Go Back   PhpDig.net > PhpDig Forums > Troubleshooting

Reply
 
Thread Tools
Old 09-26-2005, 06:21 PM   #1
moreorless
Green Mole
 
Join Date: Jul 2005
Posts: 2
Cron reindexing not working

Hi

I've managed to set a cron job for the periodic reindexing on my website. It appears to be functioning as a new spider log is produced each time the job runs. However, the reindexing does not appear to get beyond the first page. The days, links and depth have been set to 0, 20 and 20 respectively in the config file, so that doesn't appear to be the issue.

Any help with this problem will be greatly appreciated.

The spider log generated each time the process runs contains the following information:

Spidering in progress...
-----------------------------
SITE : http://www.otsi.nsw.gov.au/
Exclude paths :
- awstats/
- bus/stats.php
- cgi-bin/
- cp/
- components/
- FAQ/
- ferry/stats.php
- images/
- media/
- phpdig/
- rail/stats.php
- templates/
- webalizer/
- calendar.php
- login.html
XDuplicate of an existing document
1:http://www.otsi.nsw.gov.au/
(time : 00:00:00)
+
level 1...
(time : 00:00:00)

No link in temporary table
links found : 1
Optimizing tables...
Indexing complete !


Thanks
moreorless is offline   Reply With Quote
Old 09-27-2005, 09:25 AM   #2
Charter
Head Mole
 
Charter's Avatar
 
Join Date: May 2003
Posts: 2,539
It looks like the page you set for reindex hasn't changed, or looks like another page that hasn't changed, since last index. On next reindex try entering the site on a page that is new or changed, or resave the main index page so to give the file an updated timestamp. Also nix this bug.
__________________
Responses are offered on a voluntary if/as time is available basis, no guarantees. Double posting or bumping threads will not get your question answered any faster. No support via PM or email, responses not guaranteed. Thank you for your comprehension.
Charter is offline   Reply With Quote
Old 10-02-2005, 11:23 PM   #3
moreorless
Green Mole
 
Join Date: Jul 2005
Posts: 2
Thumbs up

Thanks Charter, that was a help.

Using forceall in the cron command also seems to have had an effect. I guess there is more than one way to skin a cat, or a mole as the case may be.

I'd like to take the opportunity to thank you and all the others involved in the development of PHPDig. It's a great product. I've been looking around for what seems like years for a sophisticated site search function that can be installed and configured by someone (i.e. me) who is not a hardcore programmer. PHPDig sure fits the bill. Great work.

Cheers
moreorless is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Working with MySql cefiro Troubleshooting 1 02-26-2005 09:19 PM
Looking for a working example.... pwoc How-to Forum 0 11-12-2004 05:38 PM
Reindexing non-existing urls AllKnightAccess Troubleshooting 0 11-06-2004 12:31 PM
Reindexing site won't index certain page gman Troubleshooting 4 08-06-2004 02:05 PM
Automatic reIndexing - How to set up 2440media How-to Forum 2 06-17-2004 06:01 AM


All times are GMT -8. The time now is 12:40 AM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Copyright © 2001 - 2005, ThinkDing LLC. All Rights Reserved.