PhpDig.net

Go Back   PhpDig.net > PhpDig Forums > Script Installation

Reply
 
Thread Tools
Old 03-01-2004, 11:53 AM   #1
blueuniverse
Green Mole
 
Join Date: Mar 2004
Posts: 10
Angry Grr, not working

OK this script looked pretty cool so I downloaded it to see what it is capable of. Unfortunately the installation doesn't seem to have done much.

First I tried to run the normal script. That just came up with 500 errors.

Now I have tried doing it manually and I get to the bit where you have to go to the /search.php file and I get the following error.

Unable to connect to database : Check the connection script.

The config in the connect.php file is this

define('PHPDIG_DB_PREFIX','');
define('PHPDIG_DB_HOST','localhost');
define('PHPDIG_DB_USER','******');
define('PHPDIG_DB_PASS','******);
define('PHPDIG_DB_NAME','blueuniv_search');

will having the username and the db name annoy anything

Last edited by blueuniverse; 03-01-2004 at 11:55 AM.
blueuniverse is offline   Reply With Quote
Old 03-01-2004, 11:55 AM   #2
blueuniverse
Green Mole
 
Join Date: Mar 2004
Posts: 10
Ok sorted it out now. Obviously having them the same does effect things.
blueuniverse is offline   Reply With Quote
Old 03-01-2004, 11:59 AM   #3
blueuniverse
Green Mole
 
Join Date: Mar 2004
Posts: 10
Ok, new problem now, it doesn't allow me into administration
blueuniverse is offline   Reply With Quote
Old 03-01-2004, 12:05 PM   #4
Charter
Head Mole
 
Charter's Avatar
 
Join Date: May 2003
Posts: 2,539
Hi, and welcome to PhpDig.net.

Do you get a popup box asking for a username and password? If not, what happens if you set PHPDIG_ADM_AUTH to zero in the config file and protect the admin directory another way such as htaccess?
__________________
Responses are offered on a voluntary if/as time is available basis, no guarantees. Double posting or bumping threads will not get your question answered any faster. No support via PM or email, responses not guaranteed. Thank you for your comprehension.
Charter is offline   Reply With Quote
Old 03-01-2004, 12:08 PM   #5
blueuniverse
Green Mole
 
Join Date: Mar 2004
Posts: 10
I do get a popup box thing. When I set the value to 0 I can get straight there.
blueuniverse is offline   Reply With Quote
Old 03-01-2004, 12:11 PM   #6
Charter
Head Mole
 
Charter's Avatar
 
Join Date: May 2003
Posts: 2,539
Hi. Okay, set PHPDIG_ADM_AUTH back to one and then set the username and password in the config file. The default username and password are admin/admin.
__________________
Responses are offered on a voluntary if/as time is available basis, no guarantees. Double posting or bumping threads will not get your question answered any faster. No support via PM or email, responses not guaranteed. Thank you for your comprehension.
Charter is offline   Reply With Quote
Old 03-01-2004, 12:15 PM   #7
blueuniverse
Green Mole
 
Join Date: Mar 2004
Posts: 10
When I type the password in it just asks for it again
blueuniverse is offline   Reply With Quote
Old 03-01-2004, 12:19 PM   #8
Charter
Head Mole
 
Charter's Avatar
 
Join Date: May 2003
Posts: 2,539
Hi. Are you typing the username/password the same case as in the config file? If so, what is your OS/setup?
__________________
Responses are offered on a voluntary if/as time is available basis, no guarantees. Double posting or bumping threads will not get your question answered any faster. No support via PM or email, responses not guaranteed. Thank you for your comprehension.
Charter is offline   Reply With Quote
Old 03-01-2004, 12:22 PM   #9
blueuniverse
Green Mole
 
Join Date: Mar 2004
Posts: 10
Yeah. I am on a RedHat9 server with Apache 1.4 I think.

My phpinfo file is here www.blueuniverse.co.uk/info.php
blueuniverse is offline   Reply With Quote
Old 03-01-2004, 01:01 PM   #10
Charter
Head Mole
 
Charter's Avatar
 
Join Date: May 2003
Posts: 2,539
Hi. It looks like your PHP is in CGI mode. From the documentation...

Authentification doesn't operate with a CGI php. In this case, uses an .htaccess file in order to protect the [PHPDIG_DIR]/admin directory.
__________________
Responses are offered on a voluntary if/as time is available basis, no guarantees. Double posting or bumping threads will not get your question answered any faster. No support via PM or email, responses not guaranteed. Thank you for your comprehension.
Charter is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cron reindexing not working moreorless Troubleshooting 2 10-02-2005 10:23 PM
Working with MySql cefiro Troubleshooting 1 02-26-2005 08:19 PM
Looking for a working example.... pwoc How-to Forum 0 11-12-2004 04:38 PM
Working with Domains bazarin How-to Forum 1 02-28-2004 03:28 PM
Phpdig is not working kernel2 Script Installation 10 12-29-2003 10:49 PM


All times are GMT -8. The time now is 12:14 AM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Copyright © 2001 - 2005, ThinkDing LLC. All Rights Reserved.