PhpDig.net

Go Back   PhpDig.net > PhpDig Forums > Troubleshooting

Reply
 
Thread Tools
Old 12-20-2004, 03:17 AM   #1
bforsyth
Green Mole
 
Join Date: Jun 2004
Posts: 22
Unhappy

Hi Guys,

I am having trouble running the spider from Cron or the command line. Seems that it is a problem with $relative_script_path - but I can't work out what it is for the life of me. I am echoing it out in spider.php and it looks right. Weird thing is that it runs OK in the browser? See output below. Any help appreciated:

PHP Code:

@truth:~$ nice --adjust=19 /usr/bin/php4 -/home/username/public_html/search/admin/spider.php http://www.globalwaterintel.com/list.php

Relative Script path---->/home/username/public_html/search
Warning
main(../includes/config.php): failed to open streamNo such file or directory in /home/username/public_html/search/admin/spider.php on line 91

Warning
main(): Failed opening '../includes/config.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear'in /home/username/public_html/search/admin/spider.php on line 91

Warning
main(../admin/robot_functions.php): failed to open streamNo such file or directory in /home/username/public_html/search/admin/spider.php on line 112

Warning
main(): Failed opening '../admin/robot_functions.php' for inclusion (include_path='.:/usr/share/php:/usr/share/pear'in /home/username/public_html/search/admin/spider.php on line 112

Fatal error
Call to undefined function:  phpdigprnmsg() in /home/username/public_html/search/admin/spider.php on line 128 
bforsyth is offline   Reply With Quote
Old 12-20-2004, 03:42 AM   #2
bforsyth
Green Mole
 
Join Date: Jun 2004
Posts: 22
Just someting a little further. If I change to the phpdig/admin directory and run the spider from there using

PHP Code:
cd public_html/search/admin/

/
usr/bin/php4 -f spider.php http://www.mysite.com 
it seems to work OK - so I am trying to work out why calling it using a full path would be any different?

Last edited by bforsyth; 12-20-2004 at 03:45 AM.
bforsyth is offline   Reply With Quote
Old 12-20-2004, 03:33 PM   #3
Slider
Orange Mole
 
Join Date: Jan 2004
Posts: 30
The fix I had to use to make cron work. Hopefully related to your problem also.
http://www.phpdig.net/forum/showthre...=6919#post6919
Slider is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble Using PHPDig over SSL rgraves Troubleshooting 1 01-03-2006 09:44 AM
Trouble with download? Charter Feedback & News 0 03-21-2005 01:04 AM
Deep trouble with spidering Dave A Troubleshooting 2 11-10-2004 12:27 AM
Problem running spider from Command Line joshuag200 Troubleshooting 17 09-13-2004 07:57 PM
$argc and $argv are empty when running spider.php from the shell bsw114 Mod Submissions 1 02-20-2004 07:52 AM


All times are GMT -8. The time now is 08:49 AM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 2001 - 2005, ThinkDing LLC. All Rights Reserved.