PhpDig.net

Go Back   PhpDig.net > PhpDig Forums > Troubleshooting

Reply
 
Thread Tools
Old 09-27-2003, 12:25 PM   #1
gbauer
Green Mole
 
Join Date: Sep 2003
Posts: 1
Wink PhpDig running with IIS and Windows XP Pro

In Portuguese:

Ao abrir a página de administração do PhpDig http://yourserver/phpdig/admin/index.php eu recebia um erro irritante tipo:
Warning: fopen(../admin/temp/8351d0f3f74bfef7ef6ef3552174b54f.tmp): failed to open stream: Permission denied in c:\inetpub\wwwroot\phpdig\admin\robot_functions.php on line 637

Isso era causado porque as pastas de trabalho do PhpDig não tinham direitos de gravação. Veja a seguir como resolvi o problema.

Para poder atribuir direitos de gravação nas seguintes pastas

[PHPDIG_DIR]/text_content
[PHPDIG_DIR]/include
[PHPDIG_DIR]/admin/temp

do PHPDIG, no caso do Windows XP Pro, faça o seguinte:

1)Primeiro você deve desmarcar a opção “Usar compartilhamento simples de arquivo” no Windows Explorer.

Veja como:

a) Abra qualquer pasta no “Windows Explorer”.

b) Abra o menu “Ferramentas”, clique na aba “Opções de pasta” e então clique na aba “Modo de exibição”.

c) Role a tela para baixo. Desmarque a opção “Usar compartilhamento simples”.

d) Depois de desmarcar a opção “Usar compartilhamento simples” dê OK. Tenha calma que pode demorar um pouco, dependendo de sua máquina. O HD trabalha um pouco....

e) Enfim! Agora você verá a aba “Segurança” ao clicar com o botão direito do mouse na pasta e selecionar “Propriedades” da pasta ou arquivo. Experimente!

2) Agora vamos ter acesso * aba “Segurança” das pastas. Faça o seguinte:

a) Clicar com o botão direito do mouse sobre cada uma das três pastas acima (uma de cada vez, é claro!) e vá para a aba “Segurança”.

b) Clique no usuário “Todos” do quadro “Nomes de grupo ou de usuário:”

c) Agora, olhe o quadro “Permissões para Todos”. Marque a opção “Gravar”. Saia d**** OK. Passe para a outra pasta e repita o procedimento.

3) Faça um teste rod**** o PHPDIG. Deve funcionar, eliminado o erro de “fopen() – access denied ...”.

4) Agora, você pode remarcar a opção “Usar compartilhamento simples de arquivo”, que é o padrão do Win XP Pro. As alterações realizadas permanecem! Boa sorte.

Agradeço a ajuda do pessoal da Internet.

This experience is my contribution to all that, like me, insisted to try PhpDig running under Windows XP Pro.

Este resumo é a minha contribuição para quem, como eu, insistiu em experimentar o PHPDIG no Win XP Pro!

In English, from the Internet:
Question:That's the part I think I'm missing because when I right click on the file
and go to the properties there is no "Security" tab, button or anything. It
does have two check boxes one for read only (unchecked) and one for Hidden.
This is the Windows Explorer version.
In the IIS properties there is a "File Security" tab, but it doesn't seem to help.
Answer: Open up any folder, let's say My Documents.
Then go to the tools menu => Folder Options.
From the "view" tab, scroll all the way down, and you should find the “simple file-sharing” checkbox.
You must "uncheck" the simple file-sharing.
Now when you right click on the folder or file, go to properties, you
should see a "Security tab".
gbauer is offline   Reply With Quote
Old 09-29-2003, 03:47 PM   #2
Charter
Head Mole
 
Charter's Avatar
 
Join Date: May 2003
Posts: 2,539
Agradecimentos para a informação.
__________________
Responses are offered on a voluntary if/as time is available basis, no guarantees. Double posting or bumping threads will not get your question answered any faster. No support via PM or email, responses not guaranteed. Thank you for your comprehension.
Charter is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Running phpdig cloefke Troubleshooting 0 07-05-2007 12:00 PM
Permissions when running phpdig from shell ! ipguy Troubleshooting 0 01-17-2006 02:33 PM
Port of PhpDig to MSSQL and IIS sfbell Mod Submissions 0 10-01-2004 05:53 AM
Indexing problems - IIS on XP darrenm Script Installation 1 05-07-2004 03:30 AM
phpDig working in IIS esadie Mod Submissions 0 02-02-2004 04:37 AM


All times are GMT -8. The time now is 04:41 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Copyright © 2001 - 2005, ThinkDing LLC. All Rights Reserved.