PDA

View Full Version : Segmentation Fault / errors parsing


unknown
04-05-2004, 04:25 AM
hello,

i have an problem when i start phpdig from the command line then i get two errors
when i start from root with "php -f /home/domain/www/admin/spider.php -all"
then i get an error "Errors parsing /home/domain/www/admin/spider.php"

when i now change to directory /home/domain/www/admin/ and start with "php -f spider.php -all" the errormessage is "Segmentation Fault"

have someone an fix for this problem?

Charter
04-10-2004, 03:57 PM
Hi. Not sure this is specific to PhpDig. Perhaps this (http://sources.redhat.com/ml/cygwin/2002-05/msg00448.html) thread might help.

unknown
04-11-2004, 03:02 AM
i have fix the problem with an little script

insert this im /etc/cron.weekly

#!/bin/bash
cd /full/path/to/phpdig_admin
./cronspider



insert this as cronspider (chown 755) in /full/path/to/phpdig_admin

/path/to/php/php -f spider.php all >> /var/log/spider.log


a little problem i have, the spider.php hang after some hours (6-15) and i must kill the PID on shell :(
is it maybe that the spider autorefresh when an time x no working is detecting?

Charter
04-11-2004, 02:03 PM
Hi. Not sure about the hang thing. Is there anything showing in your error logs?

unknown
04-11-2004, 02:19 PM
no sorry no inserts in the error-log :(

Charter
04-11-2004, 02:22 PM
Hi. When you tail -f spider.log do entries keep appearing in the spider.log or what happens?

unknown
04-11-2004, 02:32 PM
in the spider.log insert the uri's where spider, when the spider.php hang up no more inserts and no error-insert in the spider.log... and after some hours (i have wait up to 12 hours) whitout an insert in spider.log i kill the prozess

Charter
04-11-2004, 02:37 PM
Hi. Try uncommenting //print $answer."<br>\n"; in the robot_functions.php file and maybe this output on next index will give a clue.

unknown
04-11-2004, 02:42 PM
ok i test it thx for your help