PDA

View Full Version : Grr, not working


blueuniverse
03-01-2004, 12:53 PM
OK this script looked pretty cool so I downloaded it to see what it is capable of. Unfortunately the installation doesn't seem to have done much.

First I tried to run the normal script. That just came up with 500 errors.

Now I have tried doing it manually and I get to the bit where you have to go to the /search.php file and I get the following error.

Unable to connect to database : Check the connection script.

The config in the connect.php file is this

define('PHPDIG_DB_PREFIX','');
define('PHPDIG_DB_HOST','localhost');
define('PHPDIG_DB_USER','******');
define('PHPDIG_DB_PASS','******);
define('PHPDIG_DB_NAME','blueuniv_search');

will having the username and the db name annoy anything

blueuniverse
03-01-2004, 12:55 PM
Ok sorted it out now. Obviously having them the same does effect things.

blueuniverse
03-01-2004, 12:59 PM
Ok, new problem now, it doesn't allow me into administration

Charter
03-01-2004, 01:05 PM
Hi, and welcome to PhpDig.net.

Do you get a popup box asking for a username and password? If not, what happens if you set PHPDIG_ADM_AUTH to zero in the config file and protect the admin directory another way such as htaccess?

blueuniverse
03-01-2004, 01:08 PM
I do get a popup box thing. When I set the value to 0 I can get straight there.

Charter
03-01-2004, 01:11 PM
Hi. Okay, set PHPDIG_ADM_AUTH back to one and then set the username and password in the config file. The default username and password are admin/admin.

blueuniverse
03-01-2004, 01:15 PM
When I type the password in it just asks for it again

Charter
03-01-2004, 01:19 PM
Hi. Are you typing the username/password the same case as in the config file? If so, what is your OS/setup?

blueuniverse
03-01-2004, 01:22 PM
Yeah. I am on a RedHat9 server with Apache 1.4 I think.

My phpinfo file is here www.blueuniverse.co.uk/info.php

Charter
03-01-2004, 02:01 PM
Hi. It looks like your PHP is in CGI mode. From the documentation...

Authentification doesn't operate with a CGI php. In this case, uses an .htaccess file in order to protect the [PHPDIG_DIR]/admin directory.