PDA

View Full Version : not spidering - ipowerweb host


paullind
02-15-2004, 10:55 AM
Hi

Has anyone setup phpdig on the ipowerweb.com host?

I've set phpdig up on other servers but can't get this one to work properly.

Here are the specs:
PHP version 4.3.2
MySQL version 3.23.
apache/unix

When I enter a webpage address to spider I get normal looking reply:

----------------------------------------------------------------------------
Spidering in progress...

SITE : http://www.nhl.com/
Exclude paths :
- @NONE@
No link in temporary table


links found : 0
...Was recently indexed
Optimizing tables...
Indexing complete !

-----------------------------------------------------------------------------
The entry shows up in the admin/index.php 'database status' 'Hosts' area and can be seen in the box area of links next to the input area but when I go to search for it no results.

The spidering process only takes 1 second so i assume no spidering is going on, also because there is a 0 for Pages, Index, Keywords, Temp Table under Database Status.

As there are entries in the 'Hosts' I assume i can connect and write to the database correctly.

What could be the most likely cause of this problem? Any assistance would be greatly appreciated.

Thanks,

Paul L
paullindgreen@hotmail.com

paullind
02-15-2004, 11:52 AM
looks like it was just a 'safe mode' issue with my host, guess I'll have to find another host.

DrKamikaze83
02-16-2004, 12:25 AM
HI paul,

i have the same problem like you. At the admin-pageeverything is write. Site is showing and so on

http://www.ebay.com


After i enter a keyword on the search.php page i get following problem:


The page cannot be found
The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.

--------------------------------------------------------------------------------

Please try the following:

If you typed the page address in the Address bar, make sure that it is spelled correctly.

Open the localhost home page, and then look for links to the information you want.
Click the Back button to try another link.
Click Search to look for information on the Internet.



HTTP 404 - File not found
Internet Explorer

Adressrow: http://localhost/index.php?site=0&path=&result_page=index.php&query_string=-agilent&search=Go&limite=10&option=exact



Can somebody help me.

Regards
Alex

Charter
02-16-2004, 02:16 PM
Hi. It looks like you may have changed the SEARCH_PAGE to be index.php but the filename is still search.php. The below constant in the config file needs to match the file called from the browser.

define('SEARCH_PAGE','search.php');

DrKamikaze83
02-17-2004, 12:02 AM
thanks for that problem, but there is a new one.

I can't get any result. Maybe the spidering doesn't work.
It always come about 20 times site is locked.

I don't now what the problem is.


Greetings
Alex

vinyl-junkie
02-17-2004, 04:26 AM
Empty the tables for your phpdig database, then try spidering your site again.