PDA

View Full Version : Phpdig is not working


kernel2
12-29-2003, 10:02 PM
I installed phpdig install.php file and it created the databases but when I goto http://www.chatfree.org/phpdig-1.6.5/admin/index.php I am getting the following error.

Table engine missing. Table excludes missing. Table keywords missing. Table sites missing. Table spider missing. Table tempspider missing. Table logs missing.

Enter password:
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 35 to server version: 3.23.56

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> show tables;
+------------------+
| Tables_in_phpdig |
+------------------+
| engine |
| excludes |
| keywords |
| logs |
| sites |
| spider |
| tempspider |
+------------------+
7 rows in set (0.00 sec)


I also configured the connect.php file

Can you please tell me how I can fix this problem? I am using Redhat, and I have php, mysql, and apache installed.

Charter
12-29-2003, 10:43 PM
Hi. Try rechecking the connect.php file as it looks like you may be connecting to the wrong database.

kernel2
12-29-2003, 10:49 PM
Originally posted by Charter
Hi. Try rechecking the connect.php file as it looks like you may be connecting to the wrong database.

Its connecting to the correct database

// Connection configuration
define('PHPDIG_DB_PREFIX','<dbprefix>');
define('PHPDIG_DB_HOST','localhost');
define('PHPDIG_DB_USER','root');
define('PHPDIG_DB_PASS','XXXX');
define('PHPDIG_DB_NAME','phpdig');


[root@cyberchatnet includes]# mysql -u root -p phpdig
Enter password:
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 78 to server version: 3.23.56

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> show tables
-> ;
+------------------+
| Tables_in_phpdig |
+------------------+
| engine |
| excludes |
| keywords |
| logs |
| sites |
| spider |
| tempspider |
+------------------+
7 rows in set (0.00 sec)

mysql>

That is no the causing the problem.

Charter
12-29-2003, 10:54 PM
Hi. Change define('PHPDIG_DB_PREFIX','<dbprefix>'); to define('PHPDIG_DB_PREFIX','');

kernel2
12-29-2003, 10:59 PM
Originally posted by Charter
Hi. Change define('PHPDIG_DB_PREFIX','<dbprefix>'); to define('PHPDIG_DB_PREFIX','');


Like this

/ Connection configuration
define('PHPDIG_DB_PREFIX','');
define('PHPDIG_DB_HOST','localhost');
define('PHPDIG_DB_USER','root');
define('PHPDIG_DB_PASS','removed');
define('PHPDIG_DB_NAME','phpdig');

//connection to the MySql server

Phil

Charter
12-29-2003, 11:01 PM
Yep, that way. ;)

kernel2
12-29-2003, 11:06 PM
I am in the admin.php and I do not see the option to add a site?

Charter
12-29-2003, 11:08 PM
Hi. Type a full URL in the text field, set the search depth, and click the dig this button.

kernel2
12-29-2003, 11:12 PM
How do I or the users add there sites, ediit the keywors and describitions?

Thank you
Phil

kernel2
12-29-2003, 11:27 PM
I am trying to add this url and its valid but its not working.

Spidering in progress...
SITE : http://bbs.chatfree.org/
Exclude paths :
- @NONE@
No link in temporary table
links found : 0
...Was recently indexed
Optimizing tables...
Indexing complete ! [Back] to admin interface.

Charter
12-29-2003, 11:49 PM
Hi. Other users cannot add sites; only the admin is able to add sites via the PhpDig control panel or shell. PhpDig sets the keywords and descriptions and uses these, so it is not advised to go and change them. Also the bbs.chatfree.org page gives the following:

The page cannot be found

The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.

--------------------------------------------------------------------------------

Please try the following:

If you typed the page address in the Address bar, make sure that it is spelled correctly.

Open the bbs.chatfree.org home page, and then look for links to the information you want.
Click the Back button to try another link.
Click Search to look for information on the Internet.

HTTP 404 - File not found
Internet Explorer