PDA

View Full Version : wierd error


nitril
12-24-2003, 07:22 AM
Hi, indexing pages did work, but when i try to search doesnt works, i get:

The XML page cannot be displayed
Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.


--------------------------------------------------------------------------------

Only one top level element is allowed in an XML document. Error processing resource 'http://localhost/phpdig-1.6.5/search.php?template_demo=.%2Ftemplates%2Fphpdig.html&site=0&path=&result_page=search.php&query_string=animais&limite=10&option=exact'. Line 2, Position 2


<b>Notice</b>: Undefined variable: match_this_spot in <b>c:\program files\apache group\apache\htdocs\phpdig-1.6.5\libs\search_function.php</b> on line <b>330</b><br />
-^


I check safe mode in php.ini:

; Safe Mode
;
safe_mode = Off

safe_mode_gid = Off

What can it be? How do I check if xml is configured right?

(I also check http://www.phpdig.net/showthread.php?s=&threadid=88&highlight=xml but it didnt help)

thank you.
- nitril

nitril
12-24-2003, 08:49 AM
Hi, i downloaded mozilla and tested with it, it showed at least the results to me (IE 5 didnt show anything, above thread), but i still get this even with mozilla:

Notice: Undefined variable: match_this_spot in c:\program files\apache group\apache\htdocs\phpdig-1.6.5\libs\search_function.php on line 330

how do i fix to work both Mozilla and IE 5 ?

thank you

-nitril

Charter
12-24-2003, 10:56 AM
Hi. Set the following at the top of the search_function.php file.

$match_this_spot = null;

nitril
12-24-2003, 11:48 AM
sweeeet, but it only works fine on Mozilla, in IE 5 i still get an error:

The XML page cannot be displayed
Cannot view XML input using XSL style sheet. Please correct the error and then click the Refresh button, or try again later.


--------------------------------------------------------------------------------

A semi colon character was expected. Error processing resource 'http://127.0.0.1/phpdig-1.6.5/search.php?template_demo=.%2Ftemplates%2Fphpdig.html&site=0&path=&result_page=search.php&query_string=camera&limite=10&option=start'. Line 117, Position 169


<b>1. <span style='font-size:10px;'>[100.00 %]</span>&nbsp;&nbsp;<a class="phpdig" href="http://www.buscape.com.br/prod_unico.asp?ordem=descr&id_prod_unico=5758&id=3482&amp;raiz=3482" target="_blank" > BuscaPé <span class="phpdigHighlight">Câmera</span> Digital Sony Cyber Shot DSC P72 </a></b><br />
------------------------------------------------------------------------------------------------------------------------------------------------------------------------^


:/ gimme some light here

compured
01-04-2004, 11:03 AM
HI,

I have the same problem.

Output:
Die XML-Seite kann nicht angezeigt werden
Die XML-Eingabe kann nicht angezeigt werden, wenn Stylesheet XSL verwendet wird. Beheben Sie den Fehler und klicken Sie dann auf Aktualisieren, oder wiederholen Sie den Vorgang später.


--------------------------------------------------------------------------------

In einem XML-Dokument ist nur ein Element höchster Ebene zugelassen. Fehler beim Bearbeiten der Ressource 'http://search.compured.net/admin/spider.php'. Zeile 2, Position 2

<b>Warning</b>: Cannot set time limit in safe mode in <b>/home/www/web1/html/searchengine/phpdig/admin/spider.php</b> on line <b>16</b><br />
-^


What do I do wrong???
Is PHPDig worth this effort?

Greetz,
Compured

Charter
01-04-2004, 12:35 PM
Hi. For the "a semi colon character was expected" warning, it looks like the style.css file and the declarations between the style tags in the templates need a bit of editing. Try the following.

Notice how the semicolons appear in the below example:

name { name: name; }
name { name: name; name: name; }
name { name: name; name: name; name: name; }

Now go through the style.css file and the style section of the templates and add in the semicolons where they are missing.

For the "cannot set time limit in safe mode" warning, your PHP is set with safe_mode enabled. You can read more about set_time_limit and safe_mode here (http://www.php.net/manual/en/function.set-time-limit.php).

compured
01-05-2004, 01:00 AM
Hi,

I don't have the semi colon problem and the safe mode is off in php.ini!

What could it be?

Compured

Charter
01-05-2004, 05:28 AM
Hi. Maybe something at this (http://www.drupal.org/book/view/3386) link might help.

compured
01-05-2004, 01:29 PM
Hi,

thanks for all your help, but I've decided to trash this app.
I don't think it's right that there are that many problems in this beta-software!

I'll find something, that works without having to invent a new server. :-((

Greetz and good bye.
Compured