PDA

View Full Version : indexing help


lowdb23
12-21-2003, 09:13 AM
Ihave installed phpdig on the following

openbsd 3.4
Apache 1.3.29
php-4.3.3
mysql 3.23.57
phpdig 1.6.5

I have four sites each in there own VirtualHost

when I index my site I get this in my apache logs and the site is not indexed.

[Sun Dec 21 10:08:24 2003] [error] PHP Warning: file(): URL file-access is disabled in the server configuration in /var/www/htdocs/phpdig/admin/robot_functions.php on line 553
[Sun Dec 21 10:08:24 2003] [error] PHP Warning: file(http://www.spininart.com/robots.txt): failed to open stream: no suitable wrapper could be found in /var/www/htdocs/phpdig/admin/robot_functions.php on line 553
[Sun Dec 21 10:08:24 2003] [error] PHP Warning: Variable passed to each() is not an array or object in /var/www/htdocs/phpdig/admin/robot_functions.php on line 554
[Sun Dec 21 10:08:24 2003] [error] PHP Warning: file(): URL file-access is disabled in the server configuration in /var/www/htdocs/phpdig/admin/robot_functions.php on line 553
[Sun Dec 21 10:08:24 2003] [error] PHP Warning: file(http://www.spininart.com/robots.txt): failed to open stream: no suitable wrapper could be found in /var/www/htdocs/phpdig/admin/robot_functions.php on line 553
[Sun Dec 21 10:08:24 2003] [error] PHP Warning: Variable passed to each() is not an array or object in /var/www/htdocs/phpdig/admin/robot_functions.php on line 554
[Sun Dec 21 10:09:05 2003] [error] PHP Warning: Invalid argument supplied for foreach() in /var/www/htdocs/phpdig/admin/robot_functions.php on line 1364


Will phpdig work for me? What do I need to fix.

Charter
12-21-2003, 01:26 PM
Hi. You might want to check and see if allow_url_fopen is On in the php.ini file or that allow_url_fopen is On in the PHP info.

lowdb23
12-21-2003, 02:08 PM
THANKS that was the ticket. This are working fine now.

Hi. You might want to check and see if allow_url_fopen is On in the php.ini file or that allow_url_fopen is On in the PHP info.