PDA

View Full Version : PHPDig 1.6.4 : No indexing


Yannick
12-02-2003, 07:33 AM
Hello,

I have install PHPDig 1.6.4 on my IIS6 server. (php/mysql)
Install is OK, but When I try to index my site following display :

Exploration des liens en cours...

--------------------------------------------------------------------------------
SITE : http://my-lan.redirectme.net/
Chemins exclus :
- @NONE@
Pas de liens dans la table temporaire

--------------------------------------------------------------------------------

liens trouvés : 0
...A été indexé récemment
Optimizing tables...
Indexation terminée !
--------------------------------------------------------------------------------
[Retour] * l'interface d'administration.

Could you help me ???
Yannick

Charter
12-02-2003, 08:12 AM
Hi. Are you using IIS to feed your site from localhost?

Yannick
12-02-2003, 08:14 AM
all my site is under iis

Charter
12-02-2003, 12:24 PM
Hi. Perhaps something in this (http://www.phpdig.net/showthread.php?threadid=127) thread helps?

Charter
12-02-2003, 01:23 PM
Hi. Can you post printouts like those in the first post of this (http://www.phpdig.net/showthread.php?threadid=80) thread?

Yannick
12-03-2003, 01:30 AM
I do not know how to obtain this logs!

But, one or two months ago, I installed phpdig 1.6.2 and I applied the modification in the robot_functions.php to allow indexing under IIS6. The indexation worked.

I have had problems since (Low space on my HDD). I killed bases and files phpdig. Later, I tried to install phpdig 1.6.3 but it did not work any more, phpdig 1.6.4 similar. I have tried to install phpdig 1.6.2 again the same problem.

I do not understand that it worked, but that ca does not work any more now

Yannick
12-03-2003, 04:12 AM
PHPDig can't index another site too .... same error ... same problem ...

Yannick
12-03-2003, 05:15 AM
IIS6 Log don't display HTTP error

Yannick
12-03-2003, 05:21 AM
When i try to index with spider.php in dos prompt same problem :
At the beginning, error display : "renice" is not recognized as an internal or external command, operable program or batch file.

Charter
12-03-2003, 07:10 AM
Hi. Go into spider.php and comment out the following line:

print @exec('renice 18 '.getmypid()).$br;

Yannick
12-03-2003, 07:25 AM
This comment resolve error in spider.php in dos prompt but don't resolve my indexing problem ...

Have you an idea for my problem ...

My env :

Windows 2003 / IIS6
PHP 4.3.4 / MySQL 4.0.16 /MyOBDC 3.51.6

PHPDig 1.6.4

=> It's all the last version ...

see my PHPInfo in attachement ...

Charter
12-03-2003, 07:32 AM
Hi. I do not have an idea. If you could get logs, maybe then I could have an idea. My guess, and it's only a guess, is that Windows 2003 / IIS6 is unhappy with PhpDig for some reason.

Yannick
12-03-2003, 07:36 AM
It could work if I install APACHE instead of IIS (always on my Windows 2003)

Yannick
12-03-2003, 07:49 AM
if PHPDIG can't write into :
[PHPDIG]\admin\temp
[PHPDIG]\include
[PHPDIG]\text-content

an error displayed ?