PDA

View Full Version : Error 500


swordfish
09-20-2005, 08:33 PM
I am trying to go to the install.php and getting an internal server error 500.

I did a search and could find an answer.

I checked my phpinfo and looks ok...

THanks

Charter
09-20-2005, 10:08 PM
What version of PhpDig are you trying to install? What versions of PHP and MySQL are you using? What type of OS are you running? Without more info... :confused:

swordfish
09-21-2005, 05:41 AM
I am tryign to install phpdig 1.8.8-rc1

I am running PHP Version 4.4.0 on a linux serve, red hat os.

Thanks for the help

Charter
09-21-2005, 08:43 AM
What version of MySQL are you running? Is your PHP mbstring enabled? If you call domain.com/dir/phpdig_logo_2.gif via your browser, do you get the 500 error (that GIF is in the main PhpDig directory)? If you change PHPDIG_ADM_AUTH from one to zero in the config file, do you still get the 500 error when trying to access install? Still trying to narrow it down... ;)

swordfish
09-21-2005, 09:30 AM
I get the 500 just by going to the phpdig directory I setup, I then change the ADM_AUTH to zero and still get the 500...

I'm running mysql version 4.1.13

Charter
09-21-2005, 09:59 AM
Sounds like it could be the htaccess file. Try sticking a # in front of each line, in various combinations, to see if one of the lines in the htaccess file is the cause.

swordfish
09-21-2005, 10:34 AM
Putting the # in front of PHP_VALUE mbstring.encoding_translation On

Did it.

Is it ok to run like this?

swordfish
09-21-2005, 10:36 AM
Actually I had to put a # in front of all the actions

# start htaccess file
#PHP_VALUE default_charset UTF-8
#PHP_VALUE mbstring.func_overload 0
#PHP_VALUE mbstring.encoding_translation On
# end htaccess file

I'm gong to run the install script.. is this ok?

swordfish
09-21-2005, 10:41 AM
I'm now getting this error which I think is due to the version of php

Fatal error: Call to undefined function: mb_eregi() in /home/odyssey/public_html/phpdig/includes/config.php on line 109

swordfish
09-21-2005, 10:50 AM
The thread I found on this error was old and no real answer.. any fix?

I appreciate your help

Charter
09-21-2005, 12:40 PM
Your PHP is not mbstring enabled. You need to enable mbstring capabilities for PhpDig 1.8.8 RC1 to work. Once enabled you should see something like "'--enable-mbstring' '--enable-mbstr-enc-trans' '--enable-mbregex'" in the top part of your PHP info page. After you get PHP mbstring enabled, set the htaccess file back to original form. There are instructions here (http://www.php.net/mbstring) and here (http://www.php.net/manual/en/install.unix.php#install.unix.apache). If you don't have permission to rebuild PHP with mbstring then you'll need to use PhpDig 1.8.7 instead.

swordfish
09-21-2005, 01:04 PM
Ok, I'm going to try version 1.8.7 and see if that works. I assume I will have to change the htaccess again.. I'll give it a try and let you know.

swordfish
09-21-2005, 01:26 PM
Now I'm getting

Can't connect to database
Verify connection datas.

I created the user and using the right prefix and password. I can manually create the tables and database if that is all this install script is doing?

swordfish
09-21-2005, 01:27 PM
Actually with the right username and password I get:

Can't connect to database
Verify connection datas.

swordfish
09-21-2005, 01:34 PM
Ignore previous 2 post.. i'm got through :)