PDA

View Full Version : Can't sign in to admin/install.php


lala1973nc
09-07-2005, 07:46 PM
When I try to sign in with my username and password the page refreshes leaving the username and password blank.

I followed the instructions and set my username and password in the config.php file and then uploaded all the files and chmoded what was necessary.

Why can't I sign in?

lala1973nc :rant:

Charter
09-07-2005, 08:51 PM
The username and password are case sensitive. Is that it? If not, what version of PhpDig are you using, and do you allow cookies?

lala1973nc
09-08-2005, 02:39 AM
The username and password are being entered just as I placed it int the config.php file. I do allow cookies and I am using phpdig-1.8.7[1].

Charter
09-08-2005, 05:32 AM
What version of PHP are you running? If your PHP is less than version 4.1.0, add the following to the top of the config file:

if (PHP_VERSION < '4.1.0') {
$_GET = &$HTTP_GET_VARS;
$_POST = &$HTTP_POST_VARS;
$_COOKIE = &$HTTP_COOKIE_VARS;
$_SERVER = &$HTTP_SERVER_VARS;
$_ENV = &$HTTP_ENV_VARS;
$_FILES = &$HTTP_POST_FILES;
$_REQUEST = array_merge($_GET,$_POST,$_COOKIE);
}

lala1973nc
09-08-2005, 11:12 AM
I am running PHP 4.3.10.

Charter
09-09-2005, 09:37 AM
Hmm, make sure you are on admin/install.php and try your username and passowrd again. ATM I cannot see why the login won't work for you, so try adding echo " A "; echo " B "; echo " C "; etcetera at various lines in libs/auth.php and see if they print onscreen when you go to login. Maybe that will provide a clue as to where the issue lies.

lala1973nc
09-09-2005, 04:19 PM
I followed your instructions and received this parse error:
Parse error: parse error, unexpected T_IF, expecting ',' or ';' in /home/theschiz/public_html/phpdig/libs/auth.php on line 48

I am clueless. I rechecked my config.php file. Username and password are definitely set. I read the script and everything looks ok.

Line 48 in the libs/auth.php file reads:
if (PHPDIG_ADM_AUTH == 1) {

I may try to reup the files to my server and try the steps again.

lala1973nc
09-09-2005, 04:30 PM
I did it. For some reason I must have missed a step but I have accessed the install.php page and I am very happy. Thanks for trying.