PDA

View Full Version : install.php not creating tables


twalker
08-26-2005, 07:33 AM
So far so good with the installation, but when I run the install.php script nothing happens...

These are the values I'm using:

Host: localhost
Port: 3306
Sock: [empty]
User: [valid MySQL user with create tables permissions]
Pass: [password for above user]
PhpDig Database: phpdig [already created on the localhost]
Tables Prefix: [empty]

When I click "Install phpdig database" I am brought back to the install.php page but there is no error and the tables are not created. I looked in the web server error log but there's nothing there either. Help!

Tim

twalker
08-26-2005, 08:59 AM
Okay, so after digging into the code a bit I found out that the tables weren't being created. I added an output for the MySQL errors where the tables are being created (line 108 in version 1.8.8-rc1) and this is what was returned:

You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=utf8 COLLATE utf8_general_ci' at line 6
You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=utf8 COLLATE utf8_general_ci' at line 8
You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=utf8 COLLATE utf8_general_ci' at line 11
You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=utf8 COLLATE utf8_general_ci' at line 14
You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=utf8 COLLATE utf8_general_ci' at line 12
You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=utf8 COLLATE utf8_general_ci' at line 7
You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=utf8 COLLATE utf8_general_ci' at line 12
You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=utf8 COLLATE utf8_general_ci' at line 6
You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=utf8 COLLATE utf8_general_ci' at line 7
You have an error in your SQL syntax. Check the manual that corresponds to your MySQL server version for the right syntax to use near 'DEFAULT CHARSET=utf8 COLLATE utf8_general_ci' at line 7


Checking the handy MySQL manual, I find a "CHARACTER SET" statement, but not a CHARSET.

Any ideas?

Tim

twalker
08-26-2005, 09:04 AM
Okay, I found the CHARSET statement:

http://dev.mysql.com/doc/mysql/en/charset-table.html

Back to work but would still take a helping hand...

Tim

Charter
08-26-2005, 09:21 AM
Do you meet these (http://www.phpdig.net/forum/showthread.php?t=1789) requirements? If so, and as you have already created the database, try choosing the create tables option instead. BTW, what version of PHP are you running?

twalker
08-26-2005, 10:20 AM
Hmm... that's good info. It sure would have saved both of us a lot of time if I would have read that ahead of time eh? :bang:


PHP 4.3.10 (cgi) (built: Dec 21 2004 10:27:48)
mysql Ver 12.22 Distrib 4.0.23a, for redhat-linux-gnu (i686)
Apache/2.0.51


So, if I don't update both MySQL and Apache, I assume that I need to go back and run PhpDig v.1.8.7 instead?

Tim

Charter
08-26-2005, 09:33 PM
PhpDig 1.8.8 RC1 Requirements: http://www.phpdig.net/forum/showthread.php?t=1789
PhpDig 1.8.7 Requirements: http://www.phpdig.net/navigation.php?action=doc#toc3

I haven't tested Apache/2.0.51 specifically, but without MySQL 4.1.7+ (possibly an earlier version of MySQL 4.1.x) you cannot run PhpDig 1.8.8 RC1.