PDA

View Full Version : Blank page after adding code mods


Brewer
07-06-2005, 12:48 PM
I'm running version 1.8.7, and everything works fine, except for indexing PDF files. When I try to index them, this is what I get:

SITE : http://www.copyright.gov/
Exclude paths :
- @NONE@
1:http://www.copyright.gov/legislation/dmca.pdf
(time : 00:00:06)
No link in temporary table

--------------------------------------------------------------------------------

links found : 1
http://www.copyright.gov/legislation/dmca.pdf
Optimizing tables...
Indexing complete !

Then I tried adding the code mods found in this (http://www.phpdig.net/forum/showthread.php?t=799) thread, and then I get a blank spider.php page when trying to index the same site.

The code mods are pretty easy, so I know I'm doing them right. I restored the original files and tried it again, and get the same results. Then I tried doing one mod at a time and trying to index the site to see if I could find out where the problem was, and it starts after I add this mod to robot_functions.php

function phpdigTempFile($uri,$result_test,$prefix='temp/',$suffix1='1.tmp',$suffix2='2.tmp') {

/*****/
echo "<br>Is result test an array: " . is_array($result_test) . "<br>";
echo "What is result test status: " . $result_test['status'] . "<br>";
echo "Use is executable is set to: " . USE_IS_EXECUTABLE_COMMAND . "<br>";
// in the next four lines change _PDF to either _MSWORD or _MSEXCEL for those binaries
echo "Index the pdf is set to: " . PHPDIG_INDEX_PDF . "<br>";
echo "Parse the pdf is set to: " . PHPDIG_PARSE_PDF . "<br>";
echo "Does parse pdf exist: " . file_exists(PHPDIG_PARSE_PDF) . "<br>";
echo "Is parse pdf executable: " . is_executable(PHPDIG_PARSE_PDF) . "<br>";
/*****/

// $temp_filename = md5(time()+getmypid()).$suffix;

Any suggestions?

Brewer
07-06-2005, 01:34 PM
Never mind, I got it worked out, and indexing PDF files.