PDA

View Full Version : Cannot Log In


tajmahal
01-18-2005, 03:58 PM
Hi,

I am in the process of installing PHPdig. I am at step 3.2.6 in the help file. Basically I am trying to log into my admin screen for the first time. Everytime i enter my user name and password, the login screen refreshes and i am left with both fields blank. No error message pops up. I believe i have installed everything correctly up to this point. I'm really new at all of this - i used dreamweaver to upload PHPdig. Please help :cry: ! Thanks.

Charter
01-18-2005, 05:01 PM
You need to accept cookies, and usernames and passwords are case sensitive. Fixed?

tajmahal
01-18-2005, 06:22 PM
Unfortunately, this did not fix the problem. I am using IE 6, I have cookies accepted, and I am typing the user names and passwords correctly. Any other ideas?

Charter
01-18-2005, 06:33 PM
Are you using v.1.8.7, and typing the username and password set in the config file?

tajmahal
01-18-2005, 06:51 PM
I am typing the username and password that I set in the config file and using 1.87. One thing I just realized is that the page does not refresh. I start my login process at /admin/install.php . When I enter my username and password, the page goes to /libs/auth.php . This new page looks identical to the login page at /admin/install.php . If i try to enter my username and password once again and hit enter, the /libs/auth.php page refreshes with the username and password fields blank. I feel as if i must be doing something wrong with the PHP; perhaps the way I uploaded it or the way my server is handling it?

Charter
01-18-2005, 06:57 PM
What version of PHP are you using?

tajmahal
01-18-2005, 07:01 PM
My server is run by HostSave. They've got PHP 4.0.6 installed

Charter
01-18-2005, 07:02 PM
Okay, what version of PhpDig are you using?

tajmahal
01-18-2005, 07:04 PM
PhpDig v.1.8.7

Charter
01-18-2005, 07:06 PM
It's a $_SERVER versus $HTTP_SERVER_VARS thing.

// put this line at the beginning of the config file
$_SERVER = $HTTP_SERVER_VARS;

tajmahal
01-18-2005, 07:14 PM
I'm sorry, that didn't seem to work either. I appreciate all your effort though :love:

Charter
01-18-2005, 07:20 PM
Oops, I'm tired. Use this instead, first thing in config file...

if (version_compare(phpversion(), '4.1.0') == -1) {
$_POST = &$HTTP_POST_VARS;
$_GET = &$HTTP_GET_VARS;
$_COOKIE = &$HTTP_COOKIE_VARS;
$_REQUEST = array_merge($HTTP_COOKIE_VARS, $HTTP_POST_VARS, $HTTP_GET_VARS);
}

tajmahal
01-18-2005, 07:25 PM
i dont think the php server understood that version_compare bit... i got an error page stating:

Fatal error: Call to undefined function: version_compare() in /nfs/-/-/-/-/-/-/phpdig/includes/config.php on line 2

(i hyphened out the absolute path in the error line up there for security reasons, but i'm sure you get the idea)

Charter
01-18-2005, 07:31 PM
Okay, don't use what I posted before, as I am tired and confused at the moment. Try just sticking this at the beginning of the config file:

// for use with PHP < 4.1.0 only
$_SERVER = &$HTTP_SERVER_VARS;
$_POST = &$HTTP_POST_VARS;
$_GET = &$HTTP_GET_VARS;
$_COOKIE = &$HTTP_COOKIE_VARS;
$_REQUEST = array_merge($HTTP_COOKIE_VARS, $HTTP_POST_VARS, $HTTP_GET_VARS);

tajmahal
01-18-2005, 07:35 PM
I suppose one doesn't get all of those stars for being idle. IT WORKED! Thank you so much! You're awesome! :chicken: