PDA

View Full Version : A little confused


badger
11-24-2004, 01:48 PM
A little confused :deal: I have read the install instructions, searched the forums, scratched my head a few times, loaded files to server 4 times, well you get the picture. Everything I have installed on remote servers have had a newbie button to config the install. I guess my problem lies with, what happens after I load the files to my server via ftp, by going to admin/install.php it asks for user password, sorry but I am stuck, even after changing it in admin/config it does not work, how do I make the intial install connect to everything. BTW:: searching for 2 months for something like this and you have the only program out there with a robust feature zone. Looks great would like to get installed so I can "dig around"
:rolleyes:

vinyl-junkie
11-24-2004, 05:30 PM
Install.php just builds your database for you, something that your web host may or may not allow to be done remotely. Try installing the database manually. Find the file called init_db.sql and run that from phpMyAdmin, or whatever tool your server has.

Change the default username and password in connect.php to whatever you want (sounds like you've already done this part), then use that same username and password when logging into the admin panel.

If that still isn't enough to get you going, tell us step by step how you've tried to setup phpdig, and we'll see if we can point you in the right direction.

badger
11-24-2004, 06:12 PM
Thanks will try this now, hope to get it up and running tonight. :banana:

badger
11-24-2004, 06:27 PM
I have made the database connection, now what? This is what happens when I try to hit the search.php file..........or the index.php file

Unable to connect to database : Check the connection script.

vinyl-junkie
11-24-2004, 06:41 PM
Find the file called _connect.php and rename it to connect.php. Also, change values for the following to whatever you setup when you defined your phpdig database: define('PHPDIG_DB_PREFIX','<dbprefix>');
define('PHPDIG_DB_HOST','<host>');
define('PHPDIG_DB_USER','<user>');
define('PHPDIG_DB_PASS','<pass>');
define('PHPDIG_DB_NAME','<database>');

badger
11-24-2004, 06:45 PM
The only thing I did not change was the top line about the dbprefix, and my host is localhost right?

vinyl-junkie
11-24-2004, 06:52 PM
The only thing I did not change was the top line about the dbprefix, and my host is localhost right?You'll have to check with your web host to determine if your database name has a prefix. Same with localhost. Only they can tell you what those settings are.

badger
11-24-2004, 06:56 PM
I am on a apache 2.0 with php and mysql with root priv. All my other stuff was localhost. This still is not up. Is the prefix holding me up? What are some examples, thanks very much for helping.

badger
11-24-2004, 07:06 PM
My permissions are rw-r-r on the 3 "includes" directory files as well, (connect config and common_words) and setup the 3 default chmods as per install instructions, and main directory to 777 ....All ok ?

vinyl-junkie
11-24-2004, 07:16 PM
If you have other databases that specify localhost, then that is probably what this needs to be.

Regarding the prefix, that is something that you typically find on a shared server. For example, my database name is username_phpdig. Username is the dbprefix and phpdig is the database name. That's what goes into both those fields in connect.php. You can also tell this by looking at phpMyAdmin and seeing if database names are shown in the format username_dbname.

Regarding directory permissions, if you have 777 on the three directories listed in the documentation that need that, you should be ok.

Are you still getting errors?

badger
11-24-2004, 07:23 PM
[Quote]Are you still getting errors?[End Quote] Yes Iam , same as before.

My server is VDS running Plesk 7.3 reloaded as control panel. Is safe mode an issue? and how would I know it is on? I mean how do I ask my server to give me my php config via a browser?

vinyl-junkie
11-24-2004, 08:45 PM
Did you just read the install directions and not the rest of the documentation (http://www.phpdig.net/navigation.php?action=doc)? You can answer a lot of your questions by reading that.

Safe mode could possibly be an issue. To find out how that is set, copy this script into a .php file and run it from your browser:

<?php
phpinfo();
?>
Are you still getting the "can't connect" error or what? I'm confused as to what specific problem you're having now.

badger
11-25-2004, 06:39 AM
Yes same error, and I have read everything available, i::think, that would pertain to my installing this script. Here is my values from your suggestion to load a php test file. Thanks again.
----------------------start-------------------
PHP Core
Directive Local Value Master Value
allow_call_time_pass_reference On On
allow_url_fopen On On
always_populate_raw_post_data Off Off
arg_separator.input & &
arg_separator.output & &
asp_tags Off Off
auto_append_file no value no value
auto_prepend_file no value no value
browscap no value no value
default_charset no value no value
default_mimetype text/html text/html
define_syslog_variables Off Off
disable_classes no value no value
disable_functions no value no value
display_errors On On
display_startup_errors Off Off
doc_root no value no value
docref_ext no value no value
docref_root no value no value
enable_dl On On
error_append_string no value no value
error_log no value no value
error_prepend_string no value no value
error_reporting 2039 2039
expose_php On On
extension_dir /usr/lib/php4 /usr/lib/php4
file_uploads On On
gpc_order GPC GPC
highlight.bg #FFFFFF #FFFFFF
highlight.comment #FF8000 #FF8000
highlight.default #0000BB #0000BB
highlight.html #000000 #000000
highlight.keyword #007700 #007700
highlight.string #DD0000 #DD0000
html_errors On On
ignore_repeated_errors Off Off
ignore_repeated_source Off Off
ignore_user_abort Off Off
implicit_flush Off Off
include_path .:/usr/share/pear .:/usr/share/pear
log_errors Off Off
log_errors_max_len 1024 1024
magic_quotes_gpc On On
magic_quotes_runtime Off Off
magic_quotes_sybase Off Off
max_execution_time 30 30
max_input_time 60 60
memory_limit 8M 8M
open_basedir /home/httpd/vhosts/carpetbot.com/httpdocs:/tmp no value
output_buffering no value no value
output_handler no value no value
post_max_size 8M 8M
precision 14 14
register_argc_argv On On
register_globals Off Off
report_memleaks On On
safe_mode On On
safe_mode_exec_dir no value no value
safe_mode_gid Off Off
safe_mode_include_dir no value no value
sendmail_from no value no value
sendmail_path /usr/sbin/sendmail -t -i /usr/sbin/sendmail -t -i
serialize_precision 100 100
short_open_tag On On
SMTP localhost localhost
smtp_port 25 25
sql.safe_mode Off Off
track_errors Off Off
unserialize_callback_func no value no value
upload_max_filesize 2M 2M
upload_tmp_dir no value no value
user_dir no value no value
variables_order EGPCS EGPCS
xmlrpc_error_number 0 0
xmlrpc_errors Off Off
y2k_compliance On On
---------------------------end-----------------------------

vinyl-junkie
11-25-2004, 07:05 AM
Since the "can't connect" error is what you're getting, it's obvious you have some settings incorrect in your database connection values. See Post #5 (above) and make sure those settings match the way you defined your database, then try again. That should get you past this one hurdle anyway.

As for safe mode, again, that could be a problem but I don't know for sure because I don't know how it would affect the server you're on. If that is a problem, read what the phpdig documentation says about that for a workaround.

badger
11-25-2004, 07:12 AM
Since the "can't connect" error is what you're getting, it's obvious you have some settings incorrect in your database connection values. See Post #5 (above) and make sure those settings match the way you defined your database, then try again. That should get you past this one hurdle anyway.

I have quadruple checked everything, cant connect is still pertsistent. When I said before that I used loclahost prior for all databases I setup, it was on my other server, which I know for a fact has safemode off, because I put in a ticket for them to turn it off. There must be something odd here if I am still having troubles.

vinyl-junkie
11-25-2004, 07:47 AM
You'll need to check with your web host. That problem isn't something we can help you with here in the forums. Sorry.

badger
11-25-2004, 09:17 AM
You'll need to check with your web host. That problem isn't something we can help you with here in the forums. Sorry.
I think you missed my point, with all respect, I know you cant turn off or on my safe mode :-) my problem is with the setup ! It will not work. What am I doing wrong? Anyone?

vinyl-junkie
11-25-2004, 10:27 AM
I wasn't talking about safe mode when I said check with your web host. You said that you were getting a "can't connect" error, yet you swear that the connect.php parameters are correct. That's what you need to check with your web host about - to see if you have the database prefix, username, password and host name correct. We can't help you with that part. :)

Charter
11-25-2004, 10:40 AM
Yep, V-J is correct. Your connect.php configuration is not matching your database information. Read this (http://www.phpdig.net/forum/showthread.php?t=422) thread and see if you did the same thing, or do as V-J suggests.

badger
11-25-2004, 12:56 PM
Yep, V-J is correct. Your connect.php configuration is not matching your database information. Read this (http://www.phpdig.net/forum/showthread.php?t=422) thread and see if you did the same thing, or do as V-J suggests.

Took out the < and the > now this comes up,

Table engine missing. Table excludes missing. Table keywords missing. Table sites missing. Table spider missing. Table tempspider missing. Table logs missing. Table clicks missing. Table site_page missing. Table sites_days_upd missing. Table includes missing.

vinyl-junkie
11-25-2004, 01:02 PM
See Post #2 in this thread regarding manual installation of the phpdig tables. :)

badger
11-25-2004, 01:08 PM
See Post #2 in this thread regarding manual installation of the phpdig tables. :)

I did run the sql querry at the beginning of my help session with you, and it took like gangbusters, made all the tables, then I tried to login, then got the connection error, then took out the < and the >, now get the above messages. The sql setup was great just uploading the script from my directory. Is there a way to check if my database is functioning correctly, because now we lost the installer by doing it manually, any checks I can run.

badger
11-25-2004, 01:28 PM
Took out the database prefix to see what happens, because I have my own server, and this now shows up. Does this help you to find a solution to my newbie-ness :-)

Table PHPDIG_DB_PREFIXengine missing. Table PHPDIG_DB_PREFIXexcludes missing. Table PHPDIG_DB_PREFIXkeywords missing. Table PHPDIG_DB_PREFIXsites missing. Table PHPDIG_DB_PREFIXspider missing. Table PHPDIG_DB_PREFIXtempspider missing. Table PHPDIG_DB_PREFIXlogs missing. Table PHPDIG_DB_PREFIXclicks missing. Table PHPDIG_DB_PREFIXsite_page missing. Table PHPDIG_DB_PREFIXsites_days_upd missing. Table PHPDIG_DB_PREFIXincludes missing.

Note the relation change from up above, me thinks this is now the prefix issue, what would be the prefix if I have my own server?

vinyl-junkie
11-25-2004, 01:42 PM
(1) Go back and read Post #10 in this thread. Then go into phpMyAdmin and see what your phpdig database name is. If your database name looks something like this:

username_dbname
your database name has a prefix. That prefix is whatever precedes the underscore. The database name is what follows the underscore. So what database name do you see?

(2) Are there any table definitions associated with that database? If not, run init_db.sql again, just like I told you previously.

If you still have problems, post back with answers to the above questions, and we'll go from there.

badger
11-25-2004, 01:47 PM
If you still have problems, post back with answers to the above questions, and we'll go from there.

Thanks for helping, I know your not a dedicated help service, and appreciate what you do on this board as well. Maybe when this gets setup, I never quit
:cool: we can talk about something that makes for better conversation. Will get back to you all. Thanks again. :yes:

badger
11-30-2004, 07:07 PM
Houston, we have lift off :santa: Thanks for everything V::J

vinyl-junkie
11-30-2004, 07:13 PM
Congratulations on getting phpdig up and running! I knew you could do it.

:banana: