PDA

View Full Version : problems with command processing


bthurlow
10-03-2003, 05:59 PM
Hey there I have a problem with command line processing for the spider. I have searched through the forum before i decided to post a message, but i had to because i found no solution to my problem.

My Setup
W2K, PHP 4.3.1x, Apache 1.3x

I have tried all kinds of different commands like to following:

php.exe -f myphpdigdir/spider.php http://www.mydomain.com

php.exe -f "myphpdigdir/spider.php" http://www.mydomain.com

php.exe -f "myphpdigdir/spider.php" mytextfiledir/mytextfile.txt

php.exe -f "myphpdigdir/spider.php mytextfiledir/mytextfile.txt"

None of them work. All it does is just reprocess everthing that is already in the database and does not add new URLs.

Please help if you can.

Thanks.

Rolandks
10-03-2003, 07:42 PM
Hmm, it must work on your system. Does it work in browser ?

Try:
CALL from promt in C:\php:

php.exe -f "D:\InetPub\wwwroot\web\phpdig\admin\spider.php" http://www.mydomain.com

-Roland-

bthurlow
10-03-2003, 07:47 PM
It works just fine from the browser. For some reason it refuses to do anything from the command line.

I have tried that call from the php dir. It just performs a respider_mode all on the exsisting sites in the database. It acts like it is not receiving the argument on the command line.

Not sure but still working with it. Let me know if you have any other ideas.

bthurlow
10-03-2003, 09:27 PM
I found the problem. For Some reason my php will not pass the global variables.

I have temporarily solved the problem by creating a second spider to process my text file from a batch program until i get my php problem fixed.

I am currently archiving a web site that is extremely large. I will let you all know how it turns out performance wise.

Also, if you all don't mind, which i'm sure you don't I'm going to start working on the search engine for this program and see if i can get some more functionality out of it. I'll let you know how that goes. And keep you all posted on both items.

Have a good one.