PDA

View Full Version : Unable to perform phpdig installation : help


pki
07-08-2004, 04:51 AM
Hello,

I've read the documentation, searched in this forum, and didn't find any answer to my problem :

I work with Linux 2.4 / PHP 4.3.2 / Apache 2.0.46

. first I tried to install phpdig 1.8.0 with install.php. Filled in the form, but the system said it was not able to create the database.
. so I created the database (phpdig), ran the init_db.sql to create the tables (worked fine), and tried to connect to search.php page -> the system answered database connection problem.

. after I deleted everything, and installed the last release (1.8.1) :
- I'm still unable to connect to admin page : message Unable to find connect.php file. !

Now I'm totally lost and have no more idea of what I could try.


Would really appreciate any help .

Thanks,

Pascal

Charter
07-08-2004, 08:12 AM
Hi. Oops, just redownload version 1.8.1 and all should be fine. Once you FTP over the files, then just go to the admin/install.php page. If you cannot create a database, then choose create tables instead. Whether you can create a database is dependent on permissions. Some hosts do not allow you to create databases, but rather they allow you to create tables within a database you already have.

RobM
07-08-2004, 12:39 PM
Hi, I've found the same thing with 1.8.1 (downloaded 1930 GMT).

However, I disabled auth, re-ran install.php successfully to create the databases, and re-enabled auth.

Just thought you might like to know!

Setup: Fedora Core 1, Apache/2.0.47 (Fedora), PHP 4.3.3 running as Apache module.

Thanks,
Rob

Charter
07-08-2004, 03:28 PM
Hi. Oops again... :o

Just re-redownload version 1.8.1 and all should be find this time. Additional info can be found in this (http://www.phpdig.net/showthread.php?threadid=1047) thread. Disabling auth.php should not be necessary any longer.

pki
07-09-2004, 04:57 AM
Good morning,

Thank you very much ! I've downloaded phpdig again, and this time the installation step worked fine.

However, I have now an error message when I run it :

"HTTP/1.1 404 Not Found - http://dsio.ses-sterling.net/robots.txt
See http://www.w3.org/Protocols/rfc2616/rfc2616-sec10.html for explanation.
404s are either dead links or something looked like a link to PhpDig so PhpDig tried to crawl it."

Pascal

Charter
07-10-2004, 07:40 AM
Hi. That is just a notice from PhpDig letting you know that you don't have a robots.txt file. Also, sometimes PhpDig thinks it found a link, but it's not, so those notices will show then too.

vinyl-junkie
07-10-2004, 09:24 AM
If you don't have a robots.txt file on your server, here (http://www.robotstxt.org/wc/exclusion-admin.html) is a very good tutorial that gives you the basics for how to put one together.

pki
07-12-2004, 06:42 AM
Many thanks to everybody.

With your help, it seems to work now.

Just a last question : to make it work, I've set the permissions to 777 for both 'admin' and 'includes' folders, and I guess that's no very secure. (it was just because I had an error message talking about permission)
Now I would like to set the right permission to each folder. Could you tell me what it should be ?

Pascal

vinyl-junkie
07-12-2004, 10:50 AM
Check out the installation instructions here (http://www.phpdig.net/navigation.php?action=doc). Basically, what it says is that temp, includes, text_content and rss directories must have 777 directory permission.

Hope this helps. :)

pki
07-12-2004, 10:36 PM
Once again : thank you very much !

Bye,

Pascal